2008年5月26日月曜日

備忘録

このエントリーをはてなブックマークに追加
Rubyでpostgresを使えるようにする
Ruby/DBI+DBD:Pgのインストール
http://rubyforge.org/projects/ruby-dbi/からruby-dbiをダウンロード
0.2.0では上手く動かなかったので、0.1.1を入れる。

tar -zxvf dbi-0.1.1.tar.gz
cd ruby-dbi
ruby setup.rb config --with=dbi,dbd_pg
ruby setup.rb setup
ruby setup.rb install


Postgresモジュールのインストール

tar -zxvf ruby-postgres-0.7.1.tar.gz
cd ruby-postgres-0.7.1
ruby extconf.rb
make
make install

0 件のコメント :

コメントを投稿